ツイート
シェア
LINEで送る
B! はてぶでブックマーク
Pocketでブックマーク
RSSフィード

sass-loader

webpack4 -> 5 移行ガイドを読んでその通りにやってみる。

Node.js image

webpackを4から5へアップデートしましたが、移行ガイドを読まずに自力でできてしまったので、改めて移行ガイドを読んでみます。

抜けがないか確認のため。設定の細かいカスタマイズをしてる人は一読する価値あり。基本設定で済ませていれば、そこまで必要はなかったかな?

続きを読む

webpackを4から5にアップデートしたら起きたこと。これはスタートに過ぎない。

Node.js image

webpackを4から5へアップデートしました。エラーはちょいちょい出ていて、うまく行ってるところ、そうじゃないところがあります。

ひとつひとつ見ていきましょう。

これは移行作業の序の口です。その後にプラグインのアップデート、エラーが出たらその修正が必要です。

続きを読む

webpack4, プラグインのバージョンアップでエラー三昧

Node.js image

webpackおなじみの、プラグインのバージョンアップでのエラー対応です。

出るわ出るわのエラー三昧で笑けてきた。

(三昧はスシだけでいい。)

ビルドツールはあまり更新をしないから出るからしょうがないんだけど、webpack5に移行するためには一旦バージョン4で最新にする必要がある。

続きを読む

webpack4, css-loaderのminimizeでエラー

Node.js image

webpackおなじみの、バージョンアップのオプション変更でエラーが出ました。

まぁこれが嫌で、たまにしかバージョンを上げないので、余計に出るんですが。

もうひとつ、あくまでwebpackはビルドツールなので不都合がない限り放置が多いというのもある。

続きを読む

webpack4, sass-loaderのoutputStyleでエラー

Node.js image

webpackおなじみの、バージョンアップのオプション変更でエラーが出ました。

まぁこれが嫌で、たまにしかバージョンを上げないので、余計に出るんですが。

もうひとつ、あくまでwebpackはビルドツールなので不都合がない限り放置が多いというのもある。

続きを読む